SQL Express and FSQL

I have installed FSQL and SQL Express (Windows XP SP2), but when I want to make a connection in FSQL, send me the next error:

“SQL Server does not allow remote connections (provider: TCP Provider, error 0)”

The TCP/IP Protocol in SQL Server Configuration Manager is Enabled.
The SQL Express and SQL Server Explorer Services are running.

Do you have any idea?

A quick google search suggests doing the following:

In the SQL Management Studio, RightClick the SQL server instance, Choose
Properties, and under Select a Page list, click Connections. Now you should
see a checkbox labelled “Allow Remote Connections to This Server”. Make sure
it is checked.

Also, check out this Microsoft knowledge base article: support.microsoft.com/default.as … -US;914277

The label “Allow Remote Connections to This Server” is checked.

I resolve this situation enabled the program SQL Manament Studio Express in the option Exceptions in Windows Firewall.

But now, I configured the data that I want to see with the Easy Chart Customizer and show the next error:

java.sql.SQLException: La conversión del tipo de datos char a datetime produjo un valor datetime fuera de intervalo.
at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:365)
at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2781)
at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2224)
at net.sourceforge.jtds.jdbc.TdsCore.isDataInResultSet(TdsCore.java:792)
at net.sourceforge.jtds.jdbc.JtdsResultSet.(JtdsResultSet.java:146)
at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQLQuery(JtdsStatement.java:424)
at net.sourceforge.jtds.jdbc.JtdsStatement.executeQuery(JtdsStatement.java:1258)
at org.apache.commons.dbcp.DelegatingStatement.executeQuery(DelegatingStatement.java:205)
at com.calmetrics.gateway.servlets.Gateway$2.run(Gateway.java:1789)
at com.calmetrics.gateway.servlets.Gateway.doDBAction(Gateway.java:2167)
at com.calmetrics.gateway.servlets.Gateway.runQuery(Gateway.java:1782)
at com.calmetrics.gateway.servlets.Gateway.doPost(Gateway.java:307)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
at com.calmetrics.gateway.ErrorReportValve.invoke(ErrorReportValve.java:98)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Unknown Source)

Make sure the correct column is selected as the timestamp, and that the column really is a “date” data type. The error occurring trying to convert a string to a date, so that says to me that either you’ve got the wrong column selected for your x-axis, or that your “timestamp” column in the database is actually a string.

Even if the data could be converted to a date, in this case the value isn’t inside the correct range for a date value. If you can’t actually change the type of the column, you might try excluding it through the WHERE clause used by the pen- which you can set by selecting the pen in the customizer, and hitting “edit”.

Hope this helps, if you need further clarification please feel free to ask.


Sure, The column selected is timestamp.

According your suggests, the dialog box error show sql sentence:

SELECT t_stamp FROM Cortes
WHERE t_stamp >= ‘2008-07-28 00:00:00’ AND t_stamp <= ‘2008-08-27 23:59:59’
ORDER BY t_stamp

I was converted the date field to char,on option WHERE, but show me same error. Now
the sql sentence has the next behaviour:

SELECT t_stamp FROM Cortes
WHERE [b]t_stamp >= ‘2008-07-28 00:00:00’ AND t_stamp <= ‘2008-08-27 23:59:59’
AND /b
AND (LEFT(CONVERT(varchar,t_stamp,120),10)<= ‘2008-08-27 23:59:59’)
ORDER BY t_stamp

I think the error is that the sentence in black label appeared, how put out the sentence marked?

I’m sorry, now I’m confused. Is this still in the Easy Chart? If so, edit one of your pens in the FactoryPMI Designer and click on the “Run Diagnostics” button - what does it say?

Ok, let me explain again,

When I configured my pen in Easy Chart, appears the next popup window error:

[b]Gateway Error 301:
SQL Error: La conversión del tipo de datos char a datetime produjo un valor datetime fuera de intervalo.

For Query: SELECT t_stamp FROM Cortes WHERE t_stamp >= ‘2008-07-30 00:00:00’ AND t_stamp <= ‘2008-08-29 23:59:59’ ORDER BY t_stamp

On: Window 1.Root Container.Easy Chart[/b]

I have converted the date field to char in the WHERE Option in Easy Chart, and now appears the next popup window error:

[b]Gateway Error 301:
SQL Error: La conversión del tipo de datos char a datetime produjo un valor datetime fuera de intervalo.

For Query: SELECT t_stamp, Cortes, Rechazos FROM Cortes WHERE t_stamp >= ‘2008-08-27 00:00:00’ AND t_stamp <= ‘2008-08-29 23:59:59’ AND (LEFT(CONVERT(varchar,t_stamp,120),10)>= ‘2008-08-27 00:00:00’) AND (LEFT(CONVERT(varchar,t_stamp,120),10)<= ‘2008-08-29 23:59:59’) ORDER BY t_stamp

On: Window 1.Root Container.Easy Chart[/b]

When I executed the “Run Diagnostics” button in some pen edition, display the next information:

[b]Table ‘Cortes’ exists.
Time Column ‘t_stamp’ exists.
Time Column ‘t_stamp’ is the correct type.
Time Column ‘t_stamp’ is indexed.
Value Column ‘Rechazos’ exists.
Value Column ‘Rechazos’ is the correct type.

Results: 0 Warnings, 0 Errors [/b]

Best Regards

I don’t think converting the timestamp to a char is a good approach, but if you wanted is write your own where clause, you could use the classic chart component, but read on…

Maybe the locale settings on your database are interpretting yyyy-mm-dd as yyyy-dd-mm, and so it is getting confused because there is no month “27”. I thought that the yyyy-mm-dd format was supposed to be culture-independent though. You can change the date format by setting the easy chart’s “Date Format” property (it is an expert level property)

Ok thanks,

I have changed the date format of “yyyy-MM-dd” to “yyyy-dd-MM” in expert level Prperty and the graph is displayed OK.

Thanks for your support

Do you mind if I ask what country you’re in? I’ve never heard of the yyyy-MM-dd format not working, this would be useful for us to know so that we can try to make it work ‘out of the box’. Actually, it would be most useful if you would log into FactoryPMI Gateway Configuration section and tell me what it said right there under “Timezone”

The TimeZone is “America/Mexico_City [GMT-6:00]”