SSO not working

I need to use SSO login,I successfully configure User Sources of type Active Directory,I’ve also set the project’s properties to SSO login and the user source to my configured Active Directory, but I didn’t log in automatically when I opened the client. I still need to enter my local account and password manually to log in.

image

Try putting the SSOHelper logger on the gateway to TRACE and launching a client.

1 Like

I had the same issue:

SSO domains did not match! Compared ‘******.local’ and ‘******’

In the gateway, in my user source, the domain has to be ******.local, but I had to specify the SSO Domain to be only ****** (without the .local) and now it works fine.

2 Likes

This thread put me on the right track but mine was case sensitive.

Domain: mycompany.com
SSO domain: MYCOMPANY

Note that this was on a company intranet.

Thank you, Joel.

1 Like

I am also getting the same error. (Need to enter credentials manually). I removed .local from domain name as I got same log as mentioned by Joel above. But still the issue persists.

I am using AD/Internal Hybrid type for user source on Ignition v8.0.15. I am getting positive response for verification of user source.

Is anything else required?