Standard Transaction group

Hi, We are using the standard transaction group to write the tag value from on PLC to another one. We are using this function for long time but now we are seeing that the for couple of standard groups, some tags are getting values from one plc but it failed to write on another plc. Can some one has an idea about that why this is happening? we are using ignition version 8.1.27.

You'll have to share actual details of the tags that aren't working correctly. And share what you may have already tried in troubleshooting.

I enabled and disable the group but it did not work. Then I created the same scenario in that group but it didnot work. The group name is Breadfreezer_Ignition_cimco. I am taking the tag value from the Bread freezer PLC and writing down on cimco PLC. In Below picture, the tags in red color square are from Bread PLC and the tags in black color square are on cimco PLC. I tried to match the datatype of both PLC tags in transaction group but it didnot help me to solve the issue.

Have you tried writing directly into the cimco PLC's tags manually (in the designer, with comms mode set to read/write)? That will help determine if the problem is in the device connection or in the transaction group.

It is not connection problem because other tag from bread PLC to Cimco PLC is writing through Ignition.

That means nothing. Try manually writing to the problem tags from the designer. If the designer can't write to them, then the transaction group won't be able to either, and it wouldn't be the transaction group's problem.

You might need IA support looking over your shoulder.

I tried to write manually from designer, I could write zero value from designer but I couldn't write 1 value from designer. When I tried to right 1 value it became zero.

Then your PLC is squashing it. Look at your PLC code.

1 Like

I am looking at Cimco PLC and that tag has a read and write permission for external access.

We already know that, as Ignition would have been refused otherwise. You need to look at the PLC's code to see what it does with these tags.

Thank You . I found the problem and solved it.