Start next row of tablegroup on next page

I have a simple report showing pump name, a simple table related to that pump, and a timeseries chart. I have 10 pumps and have used one parent query and two child queries to populate the data. I have created one tablegroup “Pumps”. I then have it go through each pump pulling data from a database to populate the pump name, table, and chart for each pump one after another.

Everything is populating correctly except the spacing. I can’t fit two pumps on one page unless I make everything alot smaller.
If I increase the overall size of the tablegroup itself it only provides information on the first pump.
If I make the table group smaller information on the second pump starts to show up on the bottom of page 1 and continues on page 2 but thats not what I want.
I have also tried configuring the tablegroup by checking and unchecking both ‘Start on new page’ and ‘New page per row’. I would think having both of those checked would be exactly what I want but does not work. It ends up only showing information for pump 1.
I also tried checking and unchecking ‘Page Break’ under the Options section of the Configure Table section where the Data Key and Grouping is shown.
I am out of ideas…how can I make this work?

When using table groups, it is common to drag keys out of the key browser and drop them on the inner tables. That is wrong. The inner references must not show the complete data key, just in the inner part. So, a column reference for a table with key @someTable@ would be @someColumn@, not @someTable.someColumn@. When you have the latter, you get just the first result.

All of my references to data sources don’t include the data key or table name.

Also if that were the case how would that affect the spacing of things?

SOLVED.
Initially I had the one tablegroup with just a details section and no header. I put a text box with the overall report title above the tablegroup that showed up on each page. I ended up adding a header section for the one table group and putting that report title into the header block.
For the overall tablegroup:
I disabled Page Break option under Configure Table configuration showing data key and row options.
I unchecked ‘Start on new page’ and checked ‘New page per row’ under Configure Table configuration showing just data key.
And voila! Each pump now gets its own page with the only difference between the information displayed pertinent to that pump.

1 Like