Stopped for a few seconds with exit code 1

Good day

Can not get Ignition Container to run, - I get a status message: Stopped for a few seconds with exit code 1

Software used: Linux Debian 12, Docker and Portainer Community v2.18

I pulled the Igninion container successfully to docker but it fails to "Play". It starts then fail after a view seconds.
If I lookin status of Portainer , The status shows "Stopped for a few seconds with exit code 1"
I tried on two PC's and on both PC's I can not get the container running.
Any suggestion, very welcome !

How exactly do you run it ?

Hi Pascal, Thx for the quick response !

I used the same method that I pulled a NodeRed Image

For Node Red I used-
I pulled the image via command -
docker run -it -p 1880:1880 -v node_red_data:/data --name mynodered nodered/node-red
After that I just press Play in Portainer (And it works)

For Ïgnition I used
I pulled the image via command-
docker run -d -p 9088:8088 --name ignition-test inductiveautomation/ignition:8.1.30 \ -n docker-test -a localhost -h 9088 -s 9043
After that I just press Play in Portainer (Its is strating but does not go to healthy)


  1. Is environment variable configurability nececary to be able to work?
  2. I did saw some examples on internet for Docker compose but not for Portainer Stacks ?

Note: I am relative new to docker and may miss someting stupid.

If you're running your Docker command under Windows via Powershell or Windows Command Prompt, the newline delimiter is not the same.

I'm wondering if that \ might be causing trouble for you.

At this point, try the following:

docker stop ignition-test
docker rm ignition-test
docker run -d -p 9088:8088 --name ignition-test -v ignition-test-data:/usr/local/bin/ignition/data inductiveautomation/ignition:8.1.31 -n ignition-test

Thanks Collins
It worked !!
Maybe it should be noted on the Docker page ( the issue with the / )