Strange behaviour in Factory SQL

From last couple of months i am observing a strange behaviour in FSQL.In some store procedure groups data from some PLC tags is not coming. All tags are from the same PLC but still this issue appear. If i put same tag in some other group it will show me value. To resolve this issue i restarted my IO server and it start working fine but still not sure that IO server is the cause of this issue.

A quick way to find out if it is your IO server would be to restart FactorySQL. It would be interesting to find out if FactorySQL connects just fine again.

Sorry i didn’t get your point pls elaborate.

Stop, then restart the FactorySQL service. You can do this at the command line with. You may have to right click the command line shortcut and click “run as administrator”.

net stop factorysql
net start factorysql

If you’re running FSQL as an “application” as opposed to a “service”, try closing the system tray application and frontend then opening it again.

I tried to restart factory sql application but it show me the sameresult. i.e. some of the tags are fine and some are with error.


Now what happens if FactorySQL keeps running and you force restart your IO server? This may be starting and stopping a service or closing then opening a program, depending on what OPC server you’re running and how it’s configured.