system.gui.openDesktop - open fullscreen

I’m using a client startup script to launch a second desktop on my second monitor for trending and so on. The window is appearing just fine, but it is not full screen, in that the windows taskbar is still visible. On the primary monitor, the taskbar is covered by the window.

How can I script the secondary desktop to be properly fullscreen?

there is a workaround here Multi monitor wrong axis precedence

We open full screen on first monitor via NCL shortcut and then run a startup script like this to open full screen on 2nd monitor–works reliably in v7.9.9 and some previous versions (not sure what version we were on when we switched to native support for 2nd desktop from previous Java workaround):

# open window on screen index 1
system.gui.openDesktop(
	screen= 1, # 2nd display
	width= 1280,
	height= 1024,
	windows= ["windowFor2ndMonitor"])

In the properties of the window opened, Start Maximized is true (not sure if this matters or not).

1 Like

Thanks guys. Turns out specifying the width and height in the system.gui.openDesktop() command did the trick. I’d have thought that setting the width and height in the window properties (and checking start maximised) would be enough, but apparently not!

1 Like

Hi,
I am dealing with similar issue.Can you please tell me what I am missing in below code line:
system.gui.openDesktop(screen=screenIndex, handle=handleName, width=1920, height=1080, windows=windowsToOpen)

Thanks

Are you trying to get your second desktop into full screen exclusive mode–no window title bar or frame? Is your primary desktop in full screen exclusive mode?
Regardless, you can force any desktop to full screen exclusive mode with code like this:

Thank you very much for your help…It worked like charm… :relaxed:

1 Like