system.serial.openSerialPort() problem

Hello! I have some very bad issue with openSerialPort command. COM5 is present on my server. When i am trying to use it in Script Playground:


my Ignition desiner closing.

Another problem with it: when i am using this script on TagChange and iPortOpenCloseCmd set to 1:

[code]sP =“sPortName”).value

if“iPortOpenCloseCmd”).value == 1:
system.tag.writeToTag(‘iAllowPortAccess’, 1)
system.tag.writeToTag(‘iAllowPortAccess’, 0)

…sPortName is a string value = “COM5”.
…gateway goes to stopped. And Web Server goes stopped too. Helpful only the restarting Ignition Gateway service to launch project.

Also trying in Script Playground use this script:

system.serial.configureSerialPort(port="COM5",\ bitRate=system.serial.BIT_RATE_9600,\ dataBits=system.serial.DATA_BITS_8,\ handshake=system.serial.HANDSHAKE_NONE,\ hardwareFlowControl=False,\ parity=system.serial.PARITY_NONE,\ stopBits=system.serial.STOP_BITS_1) system.serial.openSerialPort("COM5")
…and Ignition goes closing.

Next step - trying to reinstall client and gateway serial modules. Same result.
Please, help.
P.S. Windows Server 2008 R2. Ignition 7.6.4, Java 7 x64

BR, Serhii Hlupak.

btw on Win XP SP3 x86 + ign 7.6.4 + java 1.7.45 where is no problem

This issue is reproducible, I will file a bug ticket to get it fixed.

We’ve updated some third party libraries that were causing this issue. The fix will be in 7.6.5-rc3.

Hello, when this version goes?

I’ll ask QA to update you when they know.

The fix will be in 7.6.5-rc3, which comes out around the middle of next week. The serial modules aren’t included in the installer, so be sure to download new versions off the Ignition downloads page when the release comes out.

Hello again. Is problem solved?

Yes, this issue was fixed in rc3, which came out a couple of days ago.

I am doing test and… the issue was not fixed!
Ignition still crash when i try to open the port :frowning:

Do you have the new serial module as well?

Will test tomorrow. But… If the modules not upgrated when the Ignition goes to update? We have the step, when we must to choose “Update installed modules” or “Select, which modules must be installed”. So, when we choose “Update installed modules”, serial module must updating to?

The serial modules aren’t included in the installer, as I mentioned in a previous post. You need to get them off the downloads page.

Ok, thanks, will try

No, issue still have. I was reinstall serial modules (client and gateway) after downloading from market.
Ignition still crashing after trying to open port.

Can you verify for us the versions of the modules that you installed?

If you go to the Gateway, under the Status tab, choose Modules and scroll down to the Serial modules. Copy and paste everything on the line “version” for both modules.

The market does not have beta/RC modules, you have to go to the “Early Access” downloads page: … ition/beta

Select “7.6 release candidate” from the dropdown, and make sure you are using this version for each of the modules:

Ok, will try

All works fine! Thanks!