I upgraded to v7.5.8 this morning and coincidentaly the following script appears to have stopped functioning.

[code]tableName = event.source.parent.parent.RecipeTable
LoadedRecipe = event.source.parent.parent.Selected_Recipe
subPath = event.source.parent.parent.subPath +"/"

numTagList = [x.strip() for x in event.source.parent.numTagList.split(’,’)]
boolTagList = [x.strip() for x in event.source.parent.boolTagList.split(’,’)]

tagString = tableName+’_ndx’
for tag in numTagList:
tagString += ‘,’ + tag
for tag in boolTagList:
tagString += ‘,’ + tag

qrySp = system.db.runPrepQuery(‘Select %s from %s Where %s_ndx = ?’ % (tagString,tableName,tableName),[LoadedRecipe])

LoadSp = list(qrySp[0])

success = system.tag.writeAll(tagList,LoadSp)
print success

the success print is returning an array of 1’s and it is not throwing an error but the tags are not updating. It worked yesterday in v 7.5.5.

Any thoughts?



I tracked down the commit that broke it - it worked until 7.5.7 and now doesn’t work in 7.5.8. I guess we’ll need a 7.5.9-beta1 going up on Monday along with the 7.6.1-beta1.


Thanks for the reply. Does this issue exist for the system.tag.write as well?

It looks like system.tag.write() can be used as a workaround for now, good idea.

I know things have been hectic there lately, but are we going to see a 7.5.9? I had to roll back to 7.5.6 from 7.5.7 and 7.5.8, both of which have fatal bugs for me.

Got a mature project that I would like to land on a good stable version…


A 7.5.9 beta/release candidate is coming soon (today, I think…). Release will follow that.

Sorry for the hassle lately.