System.util.retarget Error

I have an application running on a 7.9.9 server [“Main”], and I was attempting to use system.util.retarget to switch to an application located on my 7.9.7 server [“Remote”]. I’m able to access the Remote server via browser as well as through client launcher etc, but when I attempt to use the retarget, I get an error that reads:

Error launching application:
SAXParseException: The declaration for the entity
“HTML.Version” must end with ‘>’.

Any suggestions? I’ve tried server name vs IP address.

if(targetName=='Project 1'):
  isIgnitionLink = 1
  gateway = 'ServerName:8088'
  projectName = 'PROJECT1'
elif(targetName=='Project 2'):
  isIgnitionLink = 1
  gateway = 'IP_ADDRESS:8088'
  projectName = 'PROJECT2'
if isIgnitionLink:

If you have solved this issue please ignore, but according to the docs you should format your remote gateway address like this:

system.util.retarget("RandomProjectName", "")

I have no idea what your error message means sorry.

Actually I am having the exact same error message as you are.
Seems to only happen after connecting, while the manifest is being downloaded.


Did you manage to resolve it?

I was not able to resolve this, unfortunately. Sorry!

If you’re on 8.0, you need to drop the /main in the redirect URL. If you’re on 7.9, the opposite is true - you need to insert the /main. It’s confusing (hence why we removed it) but required when in 7.9.

Since upgrading to 8 I have no idea how to get the diagnostic console up?
Also is there any compatibility issues between releases?

My setup is as follows:
Local Server:

  • Ignition - 8.0.2
  • Java - 11.0.3+7-LTS

Remote Server:

  • Ignition - 7.8.2
  • Java - 1.8.0_101

The command I am using:

system.util.retarget("RemoteProjectName", "RemoteProjectIP:8088")

Retargeting between 7.x and 8 isn’t possible.


Thanks for clearing that up.
Will cease attempting to do so.