[Tab Container] Components/Param/Disabled

Hello.
I’m having an issue with Tab Containers.
As soon as the View is loaded, the Tab Container content style is set to disabled: in this way opacity is set to 0.25. I’d like to understand how to avoid this behaviour, but I’m a novice, so any help will be greatly appreciated. :grinning:

EDIT
I’ve found out that the faceplate classes are bound to the below script. From what I can get, Components/Param/Disabled is set if a value has not been received from the back-end (i.e.: PLC).
This application is kind of slow loading parameters from the PLC: is there a way to modify the Tag Transform script so that I can fix this issue?

Fix what “issue”? The “slow” loading, or just the removal of the disabled appearance?

There’s not a way to really speed up a PLC or its bindings. If you just don’t want the View to appear as disabled, you can remove the binding and just pass the style as the non-disabled style: “Components/Param/TabContents”. Better yet, in whatever View is being used within the tab, you could remove the style reliance on the parameter since you are no longer passing dynamic values and just set the styling of the View (or individual components) to ““Components/Param/TabContents””

1 Like

Also btw i dont think turning the cursor into ‘not allowed’ actually prevents any clicks, so i hope you do have the extra security on the buttons themselves:)

1 Like

The removal of the disabled appearance: sorry if I wasn’t clear in my question.
I’ll do as you suggest. Thank you!

I’m trying to fix the code left by other people, so any suggestion is really appreciated. I’ll surely check if they put checks on buttons and fields and I’ll remove the “not allowed” cursor. To be honest I think they went for that approach to show that the data are still loading, but the way the script is written is not going to enable the tabs at all: I’ve already found a fix to that.

Thank you!

Maybe a better cursor would be ‘wait’ for this then ^^

1 Like