Table auto adjust

I find that tables do not auto-adjust well to screen zoom changes in Perspective.

This is a table that uses an embedded view in the 3rd column. When I am at zoom 100% or less, everything is good. When I start to zoom in the table does not adjust well, even if I use overflow >> hidden.

What is everyone’s method for preventing things like this?

It is not immediately apparent to me looking at the available parameters how to make this auto-adjust perfectly.

100% Zoom

110% Zoom



Bump and adding that I frequently use the table component because it has a ton of cool features like embedded views and sub views. I just want it to react to screen size changes better out of the box.


Its probably going to depend quite a bit on what container types are used, both in the embedded view and the main view.

I’m guessing with the drawing and other components you are using a coordinate container? Without attempting to rebuild something similar, I’d see if switching to ‘Percent’ mode instead of ‘Fixed’ helps. That way it doesn’t try and fit a zoomed table in the same coordinate space. Or try swapping your overflow setting from the embedded view component to the view being embedded (or visa versa).