Table number formatting not working

I have a dataset memory tag within a UDT that contains a row of integer indexes and a row of doubles:

I’d like to render the doubles as percentages, and have setup the formatting as follows:

However, the column doesn’t seem to follow that rule:

What’s going on here?

I just tried this out, and I was able to format a column correctly with the percent sign and everything. The way I did it was using this as the format string:

0.00%

Note that I didn’t put single quotes around the percent sign (%). I just appended it to the end of the string. However, just to make sure that I was doing it right, I put the percent sign in single quotes the way you did, and it divided all the values in my column by 100 and rounded the number to the nearest 100th place.

So maybe try it both ways?

1 Like

No formatting option is working for my power table, not even the presets.

Found the issue: someone had overridden the getDisplayTextAt extension function on the table. :cold_sweat:

Thanks for your help!

2 Likes