Table.Print prints a blank table

I have a power table that has a print button with the following script

table = event.source.parent.getComponent('PO Table')
header ="[Client]Created_PO").value

It prints perfectly from my development computer, but from the client computer it will print everything but the table data. It prints the header, the table outline, the table background, but not text inside the table. I’m assuming this has something to do with the computer itself. Anybody have a suggestion on whether this is a java thing, printer driver issue, or what?

I’m having the same issue. Only no header in my script. My print button is on a template but when I publish I don’t get the data. I’ve used other print buttons like this with no issues.

Are you in 7.9? This looks like it is going to be fixed for the newest version 7.9.14 which should be released in the coming weeks.

I was seeing the same issue, but only when trying to do a table.print (exact code below) when launching via the Windows Native Client Launcher. It worked fine when not using the NCL, but when lauching with NCL the table is printed, but all cells were blank.

I just upgraded to v7.9.14 and the issue appears to be resolved.


I’m having this issue with 7.9.14. If I run using the NCL (which all of our production clients use) I get an empty table.

Did you update the NCL on the clients to the one from 7.9.14? And ensure that each is using the bundled JRE?

Thanks/sorry, yes I should’ve mentioned the client launcher version is 7.9.14. Task manager confirms the azul zulu JRE