Tag Error Icon - Cannot view or add tags

Hello,

I am having an error icon under that top level tags folder. I cannot view any of my tags, or create new ones in that folder. I don’t believe this happened immediately following moving/creating/deleting tags like others have had this problem with. I have tried restarting the gateway and refreshing the tags with no luck. The tags that were there before weren’t important and if I need to start over or delete all tags that would be fine.
I am using an Ignition Edge project if that helps anything too.

Thank you,

easiest thing to do in situations like this is to jump in gateway and see if you have connection, this to me seems you have some sort of Gateway issues…
If your gateway is functioning check out the Log section and go through the logs and see if you find something.

Check the designer’s console as well (Ctrl + Shift + C); this may give you a better indication of the problem, such as a message with 'unable to find tag provider default', ‘unable to connect to remote provider’, etc

1 Like

The Gateway Network Connection shows as running (Status->Connections->Gateway Network), and when I reset the Gateway I got two errors in the Log:

WSConnection -> outgoing local=‘ignition-win-7n50moaqh4j’ remote=‘127.0.0.1:8088’ method=senderConnect: 1505238943143 Connection attempt to ws://127.0.0.1:8088/main/system/ws-control-servlet?name=ignition-win-7n50moaqh4j&url=http://192.168.100.248:8088/main/system failed! Response code=503, error message=org.eclipse.jetty.websocket.api.UpgradeException: Didn’t switch protocols, expected status <101>, but got <503>

WSWebSocket -> outgoing local=‘ignition-win-7n50moaqh4j’ remote=‘127.0.0.1:8088’ method=onError: [100], message=Web socket is reporting an error: responseCode=503, requestURI=ws://127.0.0.1:8088/main/system/ws-control-servlet?name=ignition-win-7n50moaqh4j&url=http://192.168.100.248:8088/main/system, message=Didn’t switch protocols, expected status <101>, but got <503>

The Designer Console had the following error when I restarted the Gateway:

10:56:06.348 [SQLTags-TreeLoader-1] ERROR com.inductiveautomation.ignition.client.sqltags.tree.TagProviderNode - Error loading tags underneath
java.lang.RuntimeException: com.inductiveautomation.ignition.client.gateway_interface.GatewayException: Unable to list tags, provider “edge” not found

I had the same problem after restoring a project from a .gwbk file. Go into Project Properties General tab and make sure the Default Provider is not set to ‘none’ under the Tag settings

Hi,
I had the exact same issue, solved like this.

Whenever you import a project from a Ignition gateway to another one, it will copy all your modules and it will put all of them in a disabled status.
Enabling this, solved me the issue. ( After only 3 hours :slight_smile: )

1 Like

Thank you for replying with this. It worked like a charm.

Project Properties inside designer, not on the web page.