Tag export/import

We are running the latest version of Ignition. Whenever we import tags that are in sub-folders, they don’t repopulate back into their sub-folders, just as they were exported. All of the tags import into the main folder, and the sub-folders are there, but with nothing in them. The sub-folder tags are lumped in the same group as the rest, under the main folder.

Also, when we are developing, if we happen to save a project after the trial has expired, before we reset it, the latest developments (that were saved)will not show up again until the trial period is reset and Ignition is restarted.


The CSV problem sounds like a problem that was fixed in 7.2.3. If you’re using that version, let me know, otherwise upgrading should take care of it.

For the other problem… where is it not showing up, exactly? If the trial has expired, all of your clients have the demo expired screen. You save, reset the trial, relaunch the clients and you get the old project? If so, it might be an issue with how project updates get pushed out and how the clients specify which version of the project they want (they should, of course, want the most recent… but maybe something is being cached and mixed up). If the order of events is different, let me know.



We are at the training session in Denver, and we discussed the tag export/import issue with Travis (before I saw your reply). He is using ver. 7.2.4 and tried the tag export/import and the tags still did not [correctly] go into the sub folders. It appeared that when the tags were exported the sub folder was not correctly placed during export??, or something like that? Anyway, the issue still exists.


Sorry, but it seems to work for me. Could you perhaps post an example CSV export? Or if the problem is IN the export procedure (that is, the files don’t have the paths in them) post the procedure you’re using to export? I know there’s not many ways, but everything I’ve tried works. For example, I create a sim device, and drag it in. It has several layers of folders. I can export and import the top level and any sub level without a problem.


It occurs when we export a sub folder, then try to import that sub folder back into the root, there is no information for that sub folder to know where in the root folder it was located.

Ah, so I’m not so sure this is a problem as much as a difference in perspective in how it should work.

Here’s the thing: both export and import are relative to the current selection. That means, you select the sub folder, export, edit, and then re-import with that sub folder selected- it will overwrite what’s there. If it wasn’t relatively, it would create another structure below it. If the import was also not relative, it would replace the structure, but it would then be impossible to import a file into a different location than it was created from.

Let me know if I’ve misinterpreted something, though.