Tag expression not working

Hi all, I have an issue regarding tag expression execution, Ignition version is 8.1.12 on an Ubuntu machine.
I have a procedure that builds a UDT from a csv file. The UDT contains more or less 1000 tags, structured inside some folders, and each tag is an expression tag that makes it point to another tag in another provider. The expression uses a python script that builds the path to point to.
The csv is not the final version, so happens that I need to update the UDT from the csv. A couple of time I’ve followed this procedure, that seems to be causing the issue:

  • I rename the actual UDT, without removing it’s tag instance (which after the rename is an instance of the renamed UDT);
  • I run the script that builds the new UDT;
  • I change the tag instance “parent data type” property putting the new UDT.

After the last point the designer freezes and I need to kill it. When I restart it, I find that the UDT instance has been created, but all the expression tags are in the “uncertain” quality state, because the expressions are not evaluated. And not only the UDT instance tags are broken, but no other expression tag is working anymore, even the most simple ones.
I tried to restart the Ignition modules, but only with a gateway restart the issue disappears.
I also tried to reproduce the problem on my local machine (v8.1.12 on Windows 10), but everything works fine.
Does anyone ever had a similar problem? I wonder if there’s another way to fix the problem without restarting the gateway, since I have not access to the machine and need to call the customer every time, which is quite embarassing…