Tag Scripting - Alarm Active Event Never Fires

I’m experiencing a (UDT) tag that has frequently been in alarm but has never triggered an Alarm Active Event. I’ve reduced the script down to a simple log entry, but still no luck.

The alarm will appear in the Alarm Status table, but no log entry in the gateway logs.

Are there other dependencies? What am I missing?

I have tried this on my local gateway and it seems to work ok.

Do you have any filters on your gateway log and do you have live values on? (Not that these are likely to be the issue, but worth checking). When you're looking at the gateway log are you looking at the same time window that your alarm occurred? Can you force an alarm condition so that you can watch the gateway for the log entry to appear?

All good points – thanks! No filters on the log and live values are on. Other log entries are received as expected. The alarm can be forced – but still no luck in the logs.

There are five alarms on this tag. I’m assuming only one alarm needs to trigger for this event to fire.