Tag write to edge gateway fails

Edge Gateway serving tags to a central server. I can see all of the tags in a perspective session, can see them from the server's designer.

If I try to write to a property from anywhere but the edge gateway designer, the write fails. The error only says Bad_AccessDenied. No other data and no entry in a log that I can find to provide me any other information.

I have no entries in the Tag Read, Tag Write, and Tag Editing Permissions boxes in the Gateway Configuration. I wanted to get all read/writes working and then add in Security Zones once complete.

The tag property is set to read/write as I can write to the tag from the Edge Designer w/o issue. It feels like it's a security setting, I'm not sure what. Help?

edit 2, slightly different looking error from perspective session:

Hi Project2501,

Just to clarify, from your Central Gateway, you receive both of those errors when trying to write to your Edge Gateway's tags? Where are those tags coming from? If you create a random memory tag on your Edge Gateway and place it in the same tag provider as your other tags, do you receive the same error while trying to write from it?

One place to check is in your Edge Gateway's Service Security settings under Config -> Security. What are the settings for your Default Provider Access Level under Tag Access? This may be set to read only.

If changing those settings does not resolve the issue, have you checked the wrapper logs in both the Edge and Central Gateways for any additional information?

Inductive Automation Support:
US Phone: 1-800-266-7798
International: 1-916-456-1045
Email: support@inductiveautomation.com


The edge gateway is onboard an Opto 22 Controller and the tags are from that PLC

Great idea! I tried this and had the same result. Can write to it from inside the edge gateway/designer but not from the central server.

I had no idea about the service security setting. It was read only , I made this change:

I still have the same issue.

So I went into the wrapper on the central, did a few more failed writes, didn't see any new entires. I don't have an SSH license for my groov device so I don't know how to get to the /usr/local/bin/ignition folder.

I changed the Service Security setting on the central server for the remote gateway from inheritied to read / write and that worked. Thanks for helping guide me to that setting. I will start to add security back to all gateways and see where I break it.

Thanks again.