Tags imported as bad quality, values are NULL

I am having trouble getting my tags to be correct. I have imported the tags from the OPC server over onto my Designer client. After doing so, all of my input and output tags seem to be bad quality. Additionally, all of the relevant values associated with those tags are NULL. I am not sure as to why this is happening. I have tried a fresh reinstall and I do believe that my connection with the PLC(Micrologix 1100) is fine according to the gateway webpage. Help would be appreciated.

Consider deleting your tags and start over, dragging just the ones you need from the OPC Browser to the Tag Browser. Test the first few to make sure they’re working before dragging and dropping others. Wimpy PLCs can’t handle subscribing to everything without some TLC. Shouldn’t be done anyways–just slows down the one’s you actually are using. Also consider creating a folder and tag name structure in Ignition that groups related tags together – the Ignition Tag organization is not required to mirror the PLC’s memory layout.

1 Like

I found that when I did a mass import of tags, only the top level tags were imported.

For example in the picture below, if I dragged the I folder into my tag browser only the I:0.0, I:0.1,…I:0.n would be imported and the sub-tags (bytes) would make up the value (in Int2 format) of the I:n tag. Then if I imported a tag that had a bit not being used or of poor quality, it would throw a bad quality error on all of my tags in that folder.

If I went in and imported the I:0.0/n tags that I was actually using, I was able to have good quality and no errors.

Hopefully this helps anyone else that may be having a similar error.

Im having the same issue but the listed solution does not work…
I have tried deleting and recreating new tags.
I have tried changing the source to boolean.
I have tried changing them to be public parameters instead of local tags.
I have tried putting them in a folder and tried them in lower case.
No matter what they still come in as bad quality.

And it is only for my booleans. Strings and Dints come in fine. Help please :frowning:

Same processor type? Other processors have different syntax for booleans.

Sorry, Processor is a AB 1769-L36ERMS

Compact Guard Logix

Logix processors expect a dot separator between word and bit.

But in my case I have a created boolean tag titled “Checkout”… where would I put a (.) separator?
Does Ignitition not do well with non-hardware addressed tags?

If the tag is truly a solo boolean (not an array of booleans), I would expect you to just have [deviceName]Checkout as your OPC item path. You may have to change the source datatype from ‘Automatic’ to boolean. If part of a structured tag, it would be something like [deviceName]SomeTag.Checkout.

Understood. I have tried changing it to Boolean instead of automatic and the result does not change. Interesting enough, if I change the quality myself to a value of 192, the rag becomes fine… Until I try to load more tags into ignition then it reverts back to being bad quality.

Is this a safety tag? I’m not sure if those are accessible with Rockwell’s published tag data access specification.

Are you saying the boolean tag in Ignition follows the boolean status in the PLC if you do this?

Yeah I tried that it whenver I added tags to the ignition server the quality would revert back to bad. So, I just selected the “Opt out of Overlay” option when addressing the tag to the component. This automatically sets the quality to 192 indefinitely. This seems like the best option for me right now. And, yes the state of the tag follows both ignition and the PLC with no complications, the tags just read as bad in ignition.

Sounds like a bug worth reporting to support.

So I found out it’s cause we have a trial running on our server for Allen Bradley devices. So all the boolean and integer tags are stained as bad quality but will still functional in terms of responding to tag changes. So until we get the full version of module, this will be an issue