Tags not showing correct data properly

So I am working on an ignition project that is connected and pulling data from several different PLCs. I got all the connections on the gateway connected and working properly and set up the tags properly to where they were showing the values correctly. However, about midway through adding all the tags, there were roughly about 5 plc connections that when i went to add their tags they all showed the data value of 0, when they definitely should not have. This isn’t just for a single tag for the PLC though, it was for all roughly 100 tags for about 5 different PLCs all just showing the data value of 0 when I know from looking at the PLC program that the values the tags were pulling data from did not have value 0. I have checked with the gateway connection and it says “connected” and pinging the PLC’s ip results in a perfectly stable connection but for some reason all the tags for the plc just show 0 and nothing else when I know for a fact the values for these tags are not 0. I have tried editing a few tags and messing with its OPC item path but anything I do either results in an “Error_Configuration” or the tag just showing the incorrect value of 0.

If anyone could give me any help or advice it would be greatly appreciated. Also if I did not explain my problem properly in any part of this post please tell me so I can clarify. Thank you in advance

Brand and model of PLC?

Which device type did you pick for your connection?

Show the OPC Item path for the problem tags.

I do not know the brand or model of the plc but that is information I can get. The device connection I chose was Allen-Bradley Logix Driver which is the only one that will show the “connected” message and the same one I used for the rest of the plc’s that worked.


This is one of the OPC item paths, but they all look the same except the final “ActualTemp” differs depending on the tag. 3 parameters are used as there is such a huge number of tags it would be too tedious to go and make the opc item path for the tags. However, even if you take out the parameters and just directly type in the whole OPC item path without the parameters, it still shows a value of 0

What do you see in the OPC browser? Do any of the actual item paths shown there match what you would expect from the parameter substitutions?

Yes it matches it perfectly, and if you were to substitute the parameters with their values it would be a character by character match to what is shown on the opc browser. Everything that I can tell seems to look as it should except the data is just stuck at 0 and I am not sure why. I didn’t write over any of the data either as I have “can write” turned off

Sounds to me you need support looking over your shoulder.

I have seen this when doing tag imports and the Scan Class(Tag Groups on 8.x) doesn’t exist on the gateway.