Tags not updating after adding to Data Type

This Ignition system has been running in Production about 6 months now, no problems.
Today I added a String tag element to a Data Type being used for OPC to my PLC.
(This String has existed in the PLC for a long time, just today I wanted to see it in Ignition)

Ass soon as I added the element, all the instances of this data type stopped updating (there are 8 instances total).
Deleting this new element from the Data Type did not fix the problem, none of the tags in any instances of this datatype are updating. Other tags to this PLC are still working fine.

In the Gateway, I tried “Refresh Browse” this driver, no improvement.
I tried turning off Enabled saving, and turning Enabled back on - no improvement.

Tag Diagnostics just shows Value: NULL, Quality: Unknown.
One point of note: when I click a button on a screen that writes to one of these tags, it writes to the PLC OK, shows that it is working, but if I change the value in the PLC, Ignition does not see the change.
In the screen shot below, you can see the buttons under SOURCE and DESTINATION. Source is connected to tag SELS. Under DESTINATION, I clicked the button for MASONRY GUN, it wrote the correct value of 1 to the PLC, but if I change the value in the PLC, the buttons do not notice. See in the tag browser the value from SELD is showing as 1, but in fact it is currently 0 in the PLC.

Ignition 7.9.8, ControlLogix PLC 1756-L72 version 19.

I needed this system running, so I restarted the Gateway. All tags began functioning normally.
I then made the same change to the Data Type that I had made earlier today, which had caused this problem, but this time everything worked OK, the new elements of all the instances of the Data Type worked correctly, no problems.

So I cannot explain what went wrong the first time, I’m not so happy about that - in this environment, restarting the Gateway was not too painful, but I am planning on deploying Ignition to a much bigger application, where a restart would probably be costly.

One last question: If I had a Redundant Gateway set up, do you think that restarting the gateways independently would have:
A) fixed the problem, and
B) allowed uninterrupted user interface?