Tags with mix of Leased and Direct scan class all run slow

However if the tags that use the Direct (Default) scan class are removed, then the Leased tags return to running fast.

I am running Ignition 7.5.6 (b1317) and all the modules for that version.

I apologize if this was covered here, but I have searched the forum and couldn’t find anything, but if I missed it, please point me in the right direction.

The only thing I could find that sounds similar was a reference in the change log:

[quote]Ignition Platform -
Fixed - Fixed a bug where a driver node would always use the lowest sampling rate it had ever
seen when determining if its value was currently stale rather than the lowest rate of
current monitored items. This only occurred if there were more than one monitored items
for the given node.This was especially likely to manifest itself when one tag from a
leased scan class and one tag from a direct scan class were subscribed to the same node.
I tried down-grading to 7.5.5, 7.5.4 and variations of OPC-UA module and AB driver (using PLC5, btw) but nothing changed, still same need to delete Direct tags before fast Leased rate. Also, I’m using latest java version 7.21

Please let me know if there is a work around to allow both scan classes to run together for the same device.


I think something was fixed for 1.5.7 of the OPC-UA module, which will be part of the Ignition 7.5.7 release.

If you could grab the beta and give it a try that would be great, because if it’s still not working right I might be able to investigate/fix for 7.5.7.

Hi Kevin,

Thanks for the quick reply. I’ll give 7.5.7 a shot and let you know.


Hi Kevin,

Unfortunately, after testing with 7.5.7 beta 5, the same problem exists, only worse because now instead of just updating slow when both Direct (Debug) and Leased exist together, the Leased keep blinking red! I used to be able to eliminate this blinking red problem by deleting the device and creating it again, but now even that doesn’t fix it.

I even tried 7.6 beta and it also doesn’t work (same as 7.5.7).

Please advise.


You know, it might just be that you’re asking for too much data at too fast a rate from a PLC5…

Calling into support and doing some troubleshooting with them might be the best way to figure out what’s going on.

One thing you can do that might help would be: on the “Levels” tab of the Console on the gateway, search for a logger named “DriverVariableNode” and turn it to DEBUG. Then let everything run for a few minutes, long enough that you’re seeing the bad qualities/overlays, and then export your logs from the console and send the logs.bin.gz to the support email address.

I only have three tags set to be leased. Everything else is set to default.

I will do as you suggest. Does uploading the log file create a ticket, or do I still need to call in to initiate?


Just give 'em a call. The logs can be uploaded here or emailed in, your choice.

Make sure to turn that logger back to INFO level once you’ve sent your logs in.

Hi Kevin,

In preparing to call on this problem, I exported the project that was using tags for the UI and changed to system.opc.readValues to test if that would be any better. It was still slow but got better when I deleted all tags with Direct (Default) scan class. It was a bit faster, but still not usable. At least the flashing red was not an issue.

Since that test didn’t improve things much, I imported the project back from disk and overwrote what I had open in the Designer, so that the project would be back to using tags. I then re-imported the tags from csv, and everything was working again.

I had 20 tags running Leased to test if things would be faster if all were the same, but now risking putting too much load on a PLC5.

Things were actually running fast now, with a slight hickup now and then. I reduced the Leased to just the 8 tags that I needed, so that now I had both Leased and Direct and it now WORKED!

Everything is working fine and no blinking red either.

It almost seems like removing the project and re-importing it helped, maybe something to do with how the lease code in Ignition works behind the scenes in clients?

Sounds like voodoo to me. I suspect the issue will come back.

Yep, voodoo… in the way Ignition processes scan classes.

Has the issue returned or is this clase “closed”?