Taskbar and Title Bar show when launched from shortcut

#1

I just upgraded to 8.0.3 a few days ago. Now I have noticed that if I launch my client from the shortcut I get a Title Bar and Taskbar. Launching from the Vision Client Launcher behaves normally (no title bar and taskbar).

Is this a bug? Something I need to adjust in the shortcut directory?

Thanks,

Lane

0 Likes

#2

Was the shortcut created by the Vision Client Launcher? If not, try that first.

0 Likes

#3

Shortcut was created by Vision Client Launcher as you suggest. Same procedure on two different clients produces the same result.

For what it is worth this worked fine in 8.0.2, it just broke with 8.0.3.

Thanks,

Lane

0 Likes

#4

I have been attempting to reproduce this locally and haven’t been able to yet. A few questions I have:

  1. Does this also occur if you recreate the shortcut from the Vision Client Launcher?
  2. Were there any changes to the installed client launcher (i.e. reinstall, movement of install, etc.)?
  3. Is there anything in the %HOMEPATH%.ignition\clientlauncher-data\designerlauncher.log log that might indicate an issue occurred?

Thanks,
Garth

0 Likes

#5

Hi Garth,

Seven days ago the issue was very repeatable. I just tried creating the shortcut again and for whatever reason this problem just disappeared…maybe all I needed was a reboot. The IP address of the server also changed between working and not working status, thus I needed to manually change it in the vision client launcher. Perhaps this change fixed the issue. Quite puzzling, but I’m happy the issue just went away.

I answered your questions just in case the problems occurs again:

  1. I have only created the shortcut from the Vision Client Launcher. Perhaps I should try a different method if there is a better one?

  2. This occurred immediately after an upgrade from 8.0.2 to 8.0.3. This is also a development project, many changes occur every day.

  3. No issue in the designer launcher log file. The visionclientlauncher log file has a few errors, but they occurred right after the upgrade and I believe they all were related to using the old 8.0.2 shortcut (which did not work).

Thanks,

Lane

0 Likes

#6

Hi Lane,

I appreciate you responding with the current status of this issue. The changing of the IP address likely has something to do with it. The shortcut that is created is essentially creating an alias to the definition stored in the Designer/Client Launchers. While it isn’t clear to me why the client partially loaded, it is something I will attempt to duplicate. It could be something with the cache allowing you to get into a state that shouldn’t be allowed.

Garth

0 Likes