TCP Driver


I can’t get the ILC 130ETH from Phoenix contact connected!
I get following status:
Devices: Connected: 0 of 1 listeners connected
Console: Error creating socket session at on port 775 Connection timed out
or Connection refused
The plc tell also that the connection is refused!
What can I do?
Please refer to attached files
Best thanks
logs.bin.gz (224 KB)

Honestly I have no idea what’s going on here, but I do see that in your code you have the IP address and it looks like you’ve configured Ignition for…

It looks like you are trying to connect two active partners, which is not possible. Your screenshot shows that you configured the connection on the Phoenix device as ‘ACTIVE’.
For a TCP connection there has to be one active partner (which is Ignition when using the driver in TCP mode) and one passive (listening) partner, which is your device.
You will have to configure a passive connection on your device and watch the ‘VALID’ output of the function block to see when the Ignition driver is connected. (see for details).


best thanks for your replies. Sorry for the mistake in the error code, the ignition server is actually and the plc is
But even as a passive listener I still get the message from ignition: Connection refused. I run the plc now in a mode that it responds to the first incoming connection, still unsuccessful!

I wonder if there is a connection to the opc ua. Does it mean that already the protocol of the tcp connection requires to be in accordance with the opc ua? It might be that phoenix doesn’t support it yet. is the anyone using Phoenix Contact ILc 1xxx with Ignition?

Best thanks

It’s a while ago since i had to deal with a phoenix controller, so i never tried to connect it to Ignition.
The error you are receiving is a little strange for a passive connection (0034h - Connection request was acknowledged negatively). A quick look to the manual shows that there is an timeout parameter in the connection string, that defaults to 500ms. My best guess is that once the FB is enabled it waits 500ms for the active partner to establish a connection and then fails with the above message. Can you see a 500 ms delay between fb activation and error when monitoring the online status?
To make sure the port is really opened on the controller you can try a simple telnet connection (on windows: telnet 47000).