Teltonika RUT initialisation


Hi guys, based on other threads where we've discussed the Tel RUT, I bought 4.

The first one (X50) off amazon, wouldn't open web interface, RMA'd it, they refunded me.

Went to a UK distributor, bought two 901's and an X50.

NONE open the web interface. Can ping the default gateway

Tried in Chrome, Firefox and (gasp) Edge.

Turned all firewalls off, Windows 10 laptop direct patch cable to LAN1 on router, WiFi off.

Tried following online instructions for boot loader and firmware updater.

Am I missing something here or am I the common denominator :\

Some progress, used my trusty 2008 XP laptop to fire up a very old firefox, this let me upload a new firmware to the 901. After that, it still won't display anything on Windows 10. Tried to force it to use http as the manual explicitly states that, not https... however it's a modern router surely that shouldn't matter =\

Of course it matters. Don't let your browser force https if the target doesn't use it. (Not a router issue, but modern browsers "helping" you be secure.)

Well, I get the same results on 2008 Firefox, on http.

Wireshark while you try to open the connection?

Something seems very strange.

Going to 'phone the distributor tomorrow when they open and ask if there are any known 'quirks'.

I've seen for example Moxa IoLogix not liking Chrome, do a constant ping, get a response, and as soon as you enter the 127.254 IP in Chrome it goes AWOL. Edge (boke!) is fine.