The ClockDriftDetector warning , this Nightmare

Hello ,
I’m using Ignition 7.7.5, I have sometimes some ClockDriftDetector warning messages.

c WARN [ClockDriftDetector ] [03:59:54,465]: Clock drift, degraded performance, or pause-the-world detected.
INFO | jvm 1 | 2016/01/19 03:59:54 | lastTime=Tue Jan 19 03:59:39 CET 2016
INFO | jvm 1 | 2016/01/19 03:59:54 | currentTime=Tue Jan 19 03:59:54 CET 2016
INFO | jvm 1 | 2016/01/19 03:59:54 | deviation from expected 1000ms delta=13527ms

I have read some topics in the forum, but I don’t understood very well the meaning of this error.
Ignition is not istalled in a Virtual Machine, and the its CPU usage is 5% and the memory is 384M of 2Gb.
So, What I should check to solve this problem?

Thank you very much


Very simply, every 1 second Ignition runs a task that checks the time. It expects it to be more or less one second since the last time. If not, it prints this. It annoys and confuses many people, but is still an extremely useful tool for detecting problems, since timing is important to many aspects of Ignition, especially networking components.

This message is showing that what should have been a 1 second gap is actually 13.5 seconds. There are essentially 3 things that could be happening:
[ul][li]The system is overloaded and everything is running slowly.[/li]
[li]This was a one time pause/delay, or at least not regular. Something like a big garbage collection event.[/li]
[li]The clock on the machine was synchronized and was pushed forward[/li][/ul]

Given what you’ve said about the system, I don’t think it’s the first two in this case. A total memory allowance of 2gb wouldn’t be big enough to case a delay in cleanup, I think. And it doesn’t sound like the system is generally overwhelmed.

That would leave the idea that the clock is generally running slowly, and then the system is synchronizing and changing it. The best support for this idea would be to look at how often this message is happening, and how similar the reported differences are.

How often is this message occurring? Can you maybe post the most recent wrapper.log file, or at least look at the last few messages and post the details? If this turns out to be the case, you can confirm it by turning off the clock synchronization temporarily, but then I think the best solution is to actually speed it up (synchronize more frequently) so that the difference doesn’t grow to be so large.


Hi Colby,

What do you mean when you write clock synchronization? About the time clock of the PC?
How can I speed up the synchronization?

In attachment the wrapper.log

Thank you very much



What version of windows is it? I know I’ve looked up instructions before, and I know it wasn’t super easy, but it was possible. If you search for “how often does windows sync time”, you’ll see a variety of useful pages. Apparently windows syncs by default 1 time per week.

In that log you sent, the message has happened 5 times in 4 months. Is this really much of a problem? It does still look like it is caused by the time sync, so changing it to happen once per day instead of once per week could help. But it doesn’t seem that you’re being overwhelmed by these messages.



What Can I to review for this, i´ve got this message every minute…

Get in contact with support. It’s most likely your garbage collection settings, if there’s truly nothing else coming through in the logs, but getting a support rep access to your system would be the best way to be sure.

@benjamin987b , where you able to figure out the issue?