Time date in perspective

I am using Ignition 8.0.13. I am having a problem getting a time/date displayed on a table.

I am logging the time when a sensor detects an object on a conveyor. The format is correct in the Database and in the Dataset Editor but is incorrect in the Designer and in a session.
Something very simple that I can not find. I hope.




Are you specifying the columns in the table? If you specify the columns then the table will recognize it is a date and should do the conversion.

I simply bound the data to the table. Looking at it with the dataset Editor shows the correct data type. Is there a table property I can edit to force the data into a date format?

Actually, if render is set to “auto”, then the value will be interpreted as a numeric value, and so will continue to display as a number. @bschroeder is on the right path, however. What you should do is make sure that you properly specify that you want that column to be rendered as a date.

Your config should look like this for each of the columns displaying a date:
Screen Shot 2020-10-19 at 11.55.59AM

Make sure that the column specifies the column name as the field value, and make sure you set the render value to be “date”.

From there, you can manipulate the date format by modifying the dateFormat property of the appropriate column.

Karma is not good to me today. I changed all three items and still get the same result.

Property

Missed one.

The field property must be set properly or it will not work, at least that has been my experience (just tried as well). But, on 8.0.16 setting to render to date does work.

Edit, for me, it doesn’t matter if render is date or auto, it will show the correct date format

The Field property is the column name from the database. Correct?
I must support some projects using 8.0.13. IT will not let me put a VM on this computer. At least not yet.

Yep.

For the table on the binding for props.data what is the Return Format set for?

dataset

I found it!!! I had a space before the field property.

Thank you all.

1 Like

it doesn`t work in 8.0.16

What type of data is your table.props.data set for?

Have you explicitly set the column field and the render for the column you want as a date?

This isn’t enough information for me to help you get it working. If you’re able to provide some insight into your data shape and a screenshot of the column configuration, I can probably help you get it working.

is it enought?

“Time Stamp” is not the name of any column in your table. Change field to have a value of “ConfirmTimestamp”.

2 Likes

I understand , when I write in field name column, then i have time)
thanks!

This method is not working

1 Like

You would need to supply a lot more information before anyone could help you.

1 Like