Time Series Chart Padding


I’m trying to set a minimal time series chart next to a linear scale and have them line up. The chart seems to have padding that I cannot get rid of. In the example below, the axis min and max is set to 0 - 30k, with some remaining space left above and below:

How can can make the chart take up all the available space?

Also, setting the axis width to 0 sets it to default width. The smallest I can get it is to set it to 1.

I don’t want to use the sparkline, as the x trace is wonderful and we need multiple plots.