Transaction group - Arrangement of columns and rows

Hi,

Is there a way to organize differently the columns and rows in Transaction Group?

I want the name of variables to be in rows, instead of columns.

Thanks in advance for your response!

Look in to block groups.

2 Likes

If it will always be one variable per row, just use the Tag Historian. That how it works.

Thanks for your response.

I haven’t precised, that I want to have a bi-directional communication, so Tag Historian won’t meet this assumption.

Block groups add rows with all variables, when one of them changes value. I am looking for a solution, where one row with one variable is added, when it changes value.

You are going to want to script your storage, then. A single project tag change script can do this. You would have it subscribed to all of the tags of interest.

1 Like

On the block group just select the “insert changed rows” option and then only the row that changed will be inserted into the database table. Should give you exactly what you want.

image

image

image

2 Likes

Works as I wanted. Thanks Duffanator!

Now I am facing other problem. When changing Memory Tag in the Designer, the new value is sent to the database, which works well. But the other way - from database to Memory Tag, it doesn’t work. The values are not updating.

Bi-directional - DB wins / OPC wins only happens at the group start to set initial values.
https://docs.inductiveautomation.com/display/DOC81/Transaction+Group+Update+Modes

Question is - why the Memory Tags are not updating, when new values are inserted to database?

Does it update when you restart the transaction group?

No, it doesnt. After restart, the values of Memory Tags are sent to the database.

Transaction groups will not poll a database to find a new value. Only tags and OPC items can conditionally trigger a transaction group.

I also think it has to do with the mode of the group. According to the docs, it seems that the group should be set to select/update, and not insert. for this to happen.

2 Likes

Yes, you’re right. After setting it to select/upadate, it works. Thank you :slight_smile: