Transaction group tag values appear N/A

I am creating a transaction group and when I drag my tags over the values appear as N/A.
They seem to be working fine in my SQL tag browser.

I have tried recreating the group.
I have tried recreating the folder the group is in.

I’m not great with transaction groups yet, so it may be a dumb error on my part, it is just puzzling that the tags work fine in the browser and in windows but lose their values in the group.

Any thoughts?

If you enable the transaction group and save the project, you should start seeing values. I imagine that showing the values as N/A when the group is disabled is probably for optimization, and if you’re troubleshooting a transaction group that might not be working the way it should, you’ll be observing the group in its enabled state.

Tried it with no success. It reads “Unable to Start.”

Also, what does “Warned” mean as a status? They will sometimes appear and then change to “running” a minute later.

I believe the “warned” status indicates the level current log message, something that is not directly an error but lets the user know that something may not be functioning as intended.

If you look at the console logs in the gateway, there should be more information about the error you received.

Down at the bottom of the group display, there is a tab for messages. You should be able to see the warning there.

Warnings usually occur because the table is missing a column or something, and “Create table” is not enabled. Or, perhaps you have multiple items set to write to the same column.

“Unable to start” is caused by similar problems, but more serious. The messages should tell you what’s wrong.

And then, the values are only updated when the group is running. They may be fine in the tag browser, but the value shown is the last value seen by group execution, which is why it’s “not available” until the group runs.


Works now. Thanks for the help!

For what it’s worth, having the tag values update in realtime even when the group isn’t running has been an outstanding feature request for a while, and will likely be in the next big update of the sql bridge module. So, don’t feel bad for asking :laughing: