Transaction groups buffer full

Greetings - shifted some transaction groups from one project to another and all started up ok.

But now some groups are failing with

1:30:50 AM B1_CIPToBoiler1 Error during group execution.

com.inductiveautomation.factorysql.evaluation.EvaluationException: java.lang.Exception: Unable to add data to memory buffer, buffer full.
at com.inductiveautomation.factorysql.evaluation.itemexecutors.SRHistoryRowExecutor.postEvaluate(
at com.inductiveautomation.factorysql.evaluation.itemexecutors.ExecutorCollection.evaluate(
at com.inductiveautomation.factorysql.evaluation.itemexecutors.ExecutorCollection.postEvaluate(
at com.inductiveautomation.factorysql.groups.AbstractItemExecutionGroup.onTriggerPostEvaluation(
at com.inductiveautomation.factorysql.groups.AbstractGroup.evaluate(
at com.inductiveautomation.factorysql.groups.AbstractGroup$
at com.inductiveautomation.ignition.common.execution.impl.BasicExecutionEngine$
at com.inductiveautomation.ignition.common.execution.impl.BasicExecutionEngine$
at java.util.concurrent.Executors$
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(
at java.util.concurrent.ScheduledThreadPoolExecutor$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Caused by: java.lang.Exception: Unable to add data to memory buffer, buffer full.
at com.inductiveautomation.ignition.gateway.history.stores.MemoryStore.insertInBuffer(
at com.inductiveautomation.ignition.gateway.history.stores.MemoryStore.syncdStoreData(
at com.inductiveautomation.ignition.gateway.history.stores.AbstractStore.storeData(
at com.inductiveautomation.ignition.gateway.history.stores.MultiStageStore.syncdStoreData(
at com.inductiveautomation.ignition.gateway.history.stores.AbstractStore.storeData(
at com.inductiveautomation.ignition.gateway.history.DefaultStoreAndForwardEngine.storeData(
at com.inductiveautomation.ignition.gateway.history.HistoryManagerImpl.storeHistory(
at com.inductiveautomation.factorysql.evaluation.itemexecutors.SRHistoryRowExecutor.postEvaluate(
… 15 more

Anything one does…eg create a new group, remove elements, recreate elements etc all fail with same error.

After reboot - all run for a short while then same issue.

These groups were running for months beforehand so am confident the issue is not with the setup.

Where to from here?

This one is weird…it was to do with the “data source” in the transaction group…it was for all groups but some fail, but not on others.

Setting it explicitly solved the issue.

I can then reset it back to and it again appears to work as expected. Some form of corruption in the import/export from other project seems likely.

What was bizzare is that all the groups ran on restart (green arrows - so have executed successfully), then at some time later some died with the error, and some stayed running…all with as the parameter.

The memory error turns out to be a bum steer…

The whole reason for moving the transaction groups int he first place is as a workaround. In our ignition webpage status it shows overview of transation groups, but then the link does not take you to the detail page as expected, so there is no way to establish which project a group is in except by memory or opening up projects in the designer…The workaround is to shift all groups to a single project so I can find them/ easily.