Trim decimals

How do you trim/truncate decimals in a LED display?
I tried changing the Number Format Pattern to ## but when project is run in vision client it still display 2 places of decimal.

You can click on the % sign in the Number Format Pattern property and select preset patterns there. The first one, #,##0 is the one it seems is typically used for no decimal places showing. It also gives you the comma to separate groups of three digits to the left of the decimal place so 12345678 would appear as 12,345,678.

A zero in the Number Format Pattern would also work, but would give no comma separator.

When the number format pattern isn’t working, the most common reason is that it is bound to something. In the designer, is the ‘Number Format Pattern’ property bold? If so, you need to click on the binding icon and select the “No Binding” option.

1 Like

Thanks binding was selected.

Great! I’m glad it worked.