Trouble starting client (JxBrowser OS error)

Hi, I’m hoping someone can point me at a solution to my problem. When I try to start a native Linux client on my Ubuntu MATE install, I get the following error just before the client opens:
“java.lang.ExceptionInInitializerError” but no further info.

Does anyone know what this means and where should I look to diagnose the problem?

Thanks for your help.


I think i’ve found the culprit - JxBrowser is not compatible with ARM architecture and its throwing this error on client startup.

It never used to do this - I could previously load clients that weren’t supported by JxBrowser and I assume the error was thrown when i tried to view those pages.

Does anyone know how to start a client that ignores the WebBrowser module?

We’ve got an open ticket for this already.

I think something changed in a newer version of JXBrowser. I don’t know if there’s a workaround right now.

You can try the 7.9.1 version of the Web Browser module - it’s a much older version of the JxBrowser module that doesn’t seem to throw the ExceptionInitializerError

Yes, I went through this with support a few weeks ago. We downgraded to the 7.9.1 version. Anything newer also throws an exception and will not load on Windows XP… Inductive said they are going to catch the exception in a newer version so unsupported clients just won’t be able to use the component, but can still launch.

Thanks for your help everyone, I downgraded the Web Browser Module to 7.9.1 version and both my XP clients and my ARM based clients worked.

I appreciate your help.