Trouble to sign modulein 7.8.3

I trie to module signer tools for signing modules for 7.8.3 :
with the followind command :

java -jar module-signer.jar -keystore=D:/install/Ignition/export_certif.jks -keystore-pwd=siai -alias=byes-siai -alias-pwd=siai -chain=D:/install/Ignition/byes_siai.p7b -module-in=D:/install/Ignition/SNMP-Basic-Driver-unsigned-1.0.6.modl -module-out=D:/install/Ignition/SNMP-Basic-Driver-signed-1.0.6.modl

I have an error :

aucun attribut manifest principal dans module-signer.jar
"No Main Manifest Attribute" in module-signer.jar

Could you please post the module-signer.jar.
I’ve build It with intelliJ/maven from

module-signer-1.0.0-SNAPSHOT.jar rename to module-signer.jar

but it doesn’t works … No main class are set into the manifest…


I’ve just updated the module-signer project on Github. Pull, and then run ‘mvn clean package’ again.

You should find two jars in the target directory, one that has “-jar-with-dependencies” in the name. That jar should be runnable now.

Thanks kevin,
could you please post here the module-signer.jar.

Ok !
I can sign a module with the :
generated and a self signed certificate.

My module is in Trial, is in Free mode.
Will check if it’s ok with a gateway waith a valide licence.

In 7.8.3 the module hook has to override the isFreeModule() method and return true/false.

could you post the link for javadoc with this method ?
have not the last sdk javadoc ? only 7.7.8 seems to be available.

With IntelliJ/Maven, can we build right now the module with this add.
Need to very quickly upgrade 2 modules for 7.8.3 with FREE licence.

What is the code to add for a FREE module : :scratch:
into public class ModuleHook extends AbstractDriverModuleHook
for a module based with AbstractDriverModuleHook ?

into public class AuditLogSplitterGatewayHook extends AbstractGatewayModuleHook
for a module based with AbstractGatewayModuleHook ?

When I add the following code in ModuleHook class

I have a compilation error.
When I decompile interface GatewayModuleHook into intellij,
I don’t find isFreeModule() method described into 7.7.8 javadoc.
data gathered from maven are from SDK 7.7.1…,

I use :


How to use 7.7.8 or 7.8.3 to be able to compile the module with isFreeModule() !!!

if I change the sdk version to 7.7.8 into my pom, I have thhe following compilation error

With :

public boolean isFreeModule(){
return true;

without @Override :blush:
compilation is OK, with 7.7.1 sdk !

I downloaded module-signer project zip file. When I extracted the zip file and run the “mvn clean package” command as you mentioned, I found this type of error shown in below. How to solve that case.

[INFO] Changes detected - recompiling the module!
[INFO] Compiling 3 source files to C:\Users\thanthm\eclipse-workspace\module-signer-master\target\classes
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:34 min
[INFO] Finished at: 2020-12-11T11:46:16+08:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.0:compile (default-compile) on project module-signer: Fatal error compiling: invalid flag: --release -> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1]

I think you’re getting this error because you’re trying to build it with JDK 8 instead of JDK 11+.

Ooo! Probably have to use an older checkout of the module-signer, then, as you need to use JDK8 to build for old Ignition.

yes. I can compile the module-signed project with jdk 11. But the module can not used because Module “client-designer-gateway-archetype Ignition Module” requires at least Ignition version 8.0.0 (b0). May I know how to signed the module for ignition verion 7.9.16. Thanks for your guidance.