Trying to connect kepware to ignition

I am trying to connect ignition version 8.1.6 to kepware version 6.4. From there kepware will be reading a few AB tags. Kepware is essentially the gateway that is being used. In ignition when creating the data base error I am trying to connect to the following destination and port. opc.tcp:// I have also tried port 1883.

This should be a simple procedure. I receive the following message. Can anyone assist?

UaException: status=Bad_ConnectionRejected,$AnnotatedConnectException: Connection refused: no further information: /

From the error message it seems you are trying to make an OPC UA connection to Kepware but you’re using the default port for MQTT instead of Kepware’s OPC UA server (49320).

The error you’re getting is just a standard networking error: connection refused. Probably because you have the wrong port.

If you get the same error even on 49320 then make sure you’ve opened your firewalls up and that Kepware is bound and active on the IP address you’re using in the endpoint URL.

This is where i get a little bit more confused. What is the endpoint url? I understood it to be the remote pc name followed by just the port 49320, is it not? Is there a specific function I need to do inside kepware to be allowed to connect? I am not using any security on kepware so anonymous logins are allowed.

Thanks, Brian!

This is the endpoint URL. You’ve got it right, but something about your environment (outside Ignition) is not allowing a TCP connection to be made to Kepware.

Common causes are that you have the wrong information, Kepware isn’t running, or a firewall is blocking the connection.

Here you can see the endpoint of the Kepware (which must be ENABLED; in my case only localhost connections are allowed. Outside connections are NOT):
and you must also trust the Ignition client certificate on the Kepserver:
and also trust the Kepserver certificate in the Ignition gateway:


Just backing up a bit here. If your end goal is to read some AB tags as in allen-bradly controller tags you don’t need keepware. Ignition has drivers that support these controllers built in:

Please ignore, if I missed something here.

Not exactly. The AB plc is in one subnet. The pc with kepware is in two different subnets, one with my pc, and one with the AB plc. Kepware is reading from one subnet and going to be supplying data to be read over the other subnet to my pc, (igntion).

Maybe there is an easier way but none that I have thought of yet.

Regards, Brian

It will be particularly important to make sure the configuration in the first screenshot from @zxcslo includes the network adapter / address for the subnet Ignition will connect from.

Ps, you should upgrade to 8.1.7 ASAP
8.1.6 was pulled due to a major bug that can remove configuration from your UDT instances under some circumstances