Trying to Link a Gateway over the internet to a Cloud-based server

I’m trying to Grab tags from a remote 8.0 gateway on a cloud-based Ignition server. Currently my cloud server is running Friday’s build and my test server is running yesterday’s build. Both servers are on 8.0. I can open the Ignition configuration pages for both servers from my “test” server.

I am testing from a network that does not have a firewall as far as I’m aware. Yesterday I tried it from the office and my certs were getting blocked by our firewall. Yesterday the cloud server wasn’t even seeing the connection attempt. From this open network the server saw the connection attempt and it allowed me to approve it from the Ignition configuration page for the cloud server.

It still doesn’t work.

From the cloud server I have approved the connection (server names redacted)

From my local “test” server it looks like this

These are the logs on the local server trying to connect to the cloud server

My IT guy told me that my public IP from this network is white listed on the cloud server. Before he did that I didn’t even see a connection attempt on the cloud server.

I’ve never tried to do this before so it’s entirely possible I’m doing something wrong.

Can someone help me determine if this is user error or a bug?

My cloud server is using a signed cert. My test server doesn’t require one currently.

You might need to have him specifically allow websocket connections - the gateway network doesn’t use HTTP*, which is probably what’s whitelisted at present.

*Technically, in 7.9 you could do GAN via long-polling HTTP requests, but that functionality has been removed from 8.0

Thanks. I’ll Check with him and follow up.

He told me this…

I have an allow-all currently set up. There is nothing left for me to open up… not sure what the problem could be – You have all ports open on TCP and UDP to the public IP address you provided.

I know he has the right IP because it didn’t work at all before he opened that up. Let me know if I can provide more information that is helpful.

If you want to try to connect to the server and see local logs I can provide information in a private channel.

Hi Steve,

Just wanted to circle back here - were you still having issues with this?

It’s resolved. We had a few issues. One issue is that our gateways were not routing to each other properly. The other was that I created one of the gateways from a backup of the other to get all my templates and stuff. That caused some of the names to be the same which broke stuff.

2 Likes