Twilio Not Connecting

Twilio is not connected on the gateway. I will paste the error soon. Does any one has documentation on configuring phone number on Twilio. I’m clue with out any documenation. Thanks. Kartik.

Here is the Image attached when I save the changes with my settings. What is the inbound hostname or port # for this configuration? Also, please keep this is in the mind that we running this on this on localhost. Thanks for your support.

Looks like a standard networking error. Are you connected to the internet? Is there a firewall blocking outbound traffic? Can you telnet to from the gateway machine?

Kevin, Thanks for your response. I appreciate it. Good news: It started working and I did not do anything. What could be the reason for this? If I click on edit and then click on save, it shows the error and after some time, it automatically removes the error. I don’t know why this happens. But the problem, it could not send the SMS message.

Secondly, My account with Twilio is trial version which will can send SMS/ voice only to one phone number ( my cell phone number). Do you think does that could be the issue? What will be inbound host and port name? I gave it as localhost and 80 was the default value that is already provided by the IA. Can you validate my settings from the images I attached? Thanks. Kartik.

The inbound settings are entirely dependent on your network setup. In order to use two-way functionality (acknowledgements) you need to have the ability to forward HTTP requests from the edge of your network to the Ignition gateway.

So the ‘public hostname’ and ‘public port’ setting might be the publicly reachable IP address of your router, which has port forwarding setup from ‘public port’ to your Ignition gateway, which allows it to receive the HTTP POST requests from Twilio’s servers.