Ubuntu Upgrade to 7.3.4

I’m running Ubuntu 11.10 64bit and attempted to upgrade to 7.3.4 today with Synaptic Package Manager. The upgrade failed apparently because the installation tried to use the administrator account I was logged in with, but only used the first 8 characters of the user name.

After I created an 8 character administrator account and re-installed with it, it worked OK. Is there some reason the install is restricted to 8 digit administrator account names (if that is the issue)? If there is, I can deal with it - just be nice to know. Thanks.

This appears to be caused specifically by using Synaptic Package Manager or Ubuntu Software Center. For some reason, the current install script cuts off the user name if it is more than 8 characters. We need to do some adjustments to the install script to fix this. In the meantime, you can use apt-get or dpkg to install or upgrade, and these programs will preserve the full user name.

Thanks for the prompt reply. I will do that.

FYI- this will be fixed in 7.3.5 (also for the upcoming 7.4 release)