UDT configuration lost

Hi, I've just experienced a scary event! On Friday I left my Ignition project up and running, no Windows, no Ignition Service restart in the meanwhile. Today my UDT instances showed up with a weird warning sign, saying that something was wrong in the UDT configuration. I tried an OPC UA module restart, but with no success. New instances of the same UDT looked good. I then decided to restart the Ignition service: after that all my UDT configurations were gone! To be more precise: one of my UDT has members which are instances of another UDT. The Value Source property of those members is overriden: the original property is Memory and the override value is Expression. That worked fine, but after Ignition service restart, all expressions were gone and the Value Source was set back to Memory.
In the wrapper.log file I found a bunch of entries like this:
[t.e.core ] [09:15:38]: Could not locate member '7b6bd986-e07e-455d-813f-c62fef64e8a7.80ce7351-740a-4780-936d-f0aa7370005c.6aa306ac-6f7b-400d-a09c-9c557449ab69' in tag 'PuntoMisuraElettrico' tag=dsGraphTypes

Any idea?

Thanks, regards

You should probably contact support for this and include a diagnostic bundle from the gateway.


1 Like

You should also collect the auto config.idb backups asap before they're lost, as one of these may have the configuration still. These are under the data/db/auto backup (or similar) folder under the ignition install directory. Unless you have a gateway backup already from prior to the issues

1 Like

Thanks guys, unfortunately I've already repaired the mess I found and I think it's too late for the Diagnostic Bundle. Anyway thanks for your suggestion, I will consider it next time .. hoping it will never happen again!

@pgmo Would you mind sharing the solution? Thank you.