UDT Query Tag Not Updating

I have a UDT instance that has a query tag set to a Leased 5 second execution rate. When I imported them in from v7.9 they were errored out from missing parameter quotes. I fixed the errors and the correct numbers were returned. Now they won’t update like the query isn’t being run. I have the execution mode set to tag group, but I tried event driven as well with no luck. I’m new to v8.1, anything I’m missing?

1 Like

Do you have anything using that query tag (in a binding)? If not, it won’t be leased. (In v7.9, the tag browser itself would establish a lease, but not in 8+.)

Yes, it is has an indirect binding to a label in the project I have open in the designer. I had a client open using it too.

Try changing it to a direct tag group, just to see if it is a leasing bug.

If I change it to Default or a to a fixed rate like every 5 seconds it works. If I try to use it as a leased tag, at 0ms rate, 5000ms leased rate for example, it never updates.

I am using v8.1 in trial mode, not sure if that is affecting it.

No, sounds like a bug.

1 Like

What is the correct/best way to make my query tags in the UDT event driven by a memory tag in the same UDT. A tag change script that runs the query and writes to those tags, or is there a better answer than I’m unaware of?

That’s probably it. Consider an event drive tag group, where changes in a query parameter drive execution.

1 Like

Event driven execution worked best I think. The only problem was that the query I was using didn’t take the driving tag (serial) as a parameter for the query, so I added this to the query to make it fire when changed. Is this a bad idea?

where cutter = '{[.]Cutter}' 
      and '{[.]Serial}' = '{[.]Serial}'
1 Like

Not a bad idea.