UDT tags copy and pasting to another UDT tags getting error

I have created a UDT1 definitions with 5 data type instance (machine1 to machine5) and I had configure the Alarms in UDT for those 5 machines.

Now I had created another UDT2 definitions with 7 data type instance (machine1 to machine7) in which machine1 to machine 5 are with same configuration as UDT1.

As machine1 to machine5 alarm configuration and scaling done in UDT1, I am trying to copy machine1 instance of UDT1 to machine1 instance of UDT2. but its not allowing me to copy and pasting and manually configuring alarms is going to be time consuming.


Suggestions and help appreciated.

If they are the same, you could make a new UDT for UDT2, and set UDT1 as a parent datatype, this should inherit any changes made to UDT1

1 Like

Thank you so much

While a parent udt sounds the best fit here, it might also be useful to know the weird gotchas with copying / pasting tags in udt instances.

  1. To paste tags from json into udt definitions, paste it into standard tags first. Copy the pasted standard tags (regular copy, not copy json) and paste them into the UDT definition within the tag browser (not the tag editor, see 2)
  2. You can't paste tag json into the tag editor
  3. You can't paste tag json into udt definitions in the tag browser
1 Like

I was copying by selecting Copy JSON and pasting it was giving same error, by doing normal copy paste it worked.
Overwriting UDT instance don't work