Unable to browse tags from WinCC v11

I have a customer that would like to use Ignition’s OPC-UA server to host tags to a Siemens Comfort Panel in WinCC v11.

In my test system I have Ubuntu 12.04 running ignition 7.5.0 RC, with good tag data from a S7-400 for testing and proof of concept.

in WinCC my connection string is “opc.tcp://” This connects but is unable to browse for tags. I tried to access a tag “[Test]MB500” without any luck.

Thanks for your time,


There won’t be any tags to browse. The tags from our Siemens driver only exist in the UA server in a way that allows them to be addressed explicitly.

That being said, you should be able to read the tags from another OPC-UA client if you get the NodeId correct.

[Test]MB500 looks valid, assuming your device is set up with the name ‘Test’ and there’s data there. If you can read data on that tag from Ignition, then my first guess would be that in the third party client you need to make sure the NodeId you’re addressing is not just ‘[Test]MB500’, but also in namespace index 1.


Thanks for the info i’m still quite lost.

Attached is a screen from from my Ignition Server and screen shots from Siemens Hotline. What is my name space and node id?


OPC_UA_Connection.pdf (134 KB)

Most of those screenshots are too blurry to see anything. Doesn’t really matter though, because I don’t know how to use that Siemens software.

You need to figure out how to read or subscribe to an arbitrary NodeId using the Siemens software that doesn’t come from a browse; a NodeId that you type in by hand.

UA NodeId’s have an identifier and a namespace index. The identifier will be ‘[Test]MB500’ and the namespace index will be 1.

I’m sorry about the image quality the forum would not allow a docx file.

the address in the screen shot is…

with connection address of opc.tcp://localhost:4847

from other documentation and this screen shot i’m guessing the address will needed to be…


but, this doesn’t work.

Try ns=1;i=[Test]MB500

ns=1;i=[Test]MB500 did not work

what is the purposes of the uri address?

uri:// … y%20Server

[quote=“buck2825”]ns=1;i=[Test]MB500 did not work

what is the purposes of the uri address?

uri:// … y%20Server[/quote]

It’s supposed to be a unique identifier for that Ignition OPC-UA server instance. You’ve actually pasted the URI to the discovery server instance rather than the regular server instance, but it doesn’t matter. I don’t think the URI is relevant here.

prosysopc.com/blog/forum/opc … ua-server/

i’m going to try to upgrade to the latest release of ignition to see it that fixes my issue.

That worked!!!
I’m now at 7.5.6

I’m still unable to browse user defined tags, as you stated would be the case, but the driver diagnostic can be browsed.


Thanks you, Keven Herron (Inductive Automation), and David Hartsell (Siemens Hotline 1-800-333-7421)

Thanks again,


Glad that’s working now. I didn’t notice you were using the 7.5.0 RC version, I would’ve suggested upgrading earlier!