Unable to Launch Vision from Launcher

Hello Everyone,

One of the client PC is having something weird going on and I was wondering if someone has experience/suggestion about it.

This client has Launcher installed and we I configure to install new client project, the project is imported but it never opens when I try. This is the screen I see. Also, as you can see I am pinging the gateway at the same time and it seems fine.

Things I tried already :
deleted all the cache, .ignition folder, even the vision client launcher was reinstalled.
Gateway opens and pings really normally.
Tried launching project from another gateway and it works fine.
Tired launching the project from another client and it works completely fine.
The client is remote on network.

The issue with specific client not being able to launch specific gateway projects.

any updates/suggestions/remarks are welcome.

Check the computer’s firewall, then if there are any other firewalls on your network i would look there.

anything in the logs?

@josborn, no issues if the Firewall. It has the exact same policy for any remote gateway within the company where one gateway works completely fine and another one doesn’t.
@andrews, not really anything in the gateway logs.

Maybe something in the user permissions of that stops it from opening?
Can you try different user account on same machine

Is the gateway actually listening on that IPv6 address?

how would I test that ?

let me try doing that

In a Linux server I would look at the output of netstat -lnp to see what is listening and on what addresses/ports. I’m sure there’s something similar for Windows.

1 Like

Something like netstat -op IPv6 should do the trick I would think.

Note @kaushik.shah you should run this on the Gateway server if that isn’t obvious

2 Likes

yup, tried that, don’t see anything there. But all the other active connections are also under netstat -a

yup, from gateway server

That means Ignition isn’t listening on IPv6, and attempts to reach it with an IPv6 address (shown in your OP) will fail.

1 Like

That is just the default ping in Windows 10 going with IPv6
Do the ping with a -4 on the end to get the IPv4 address
Then try connecting to it by the IPv4 address instead of the netbios name.

1 Like

The issues was with IPv6. The VPN user was trying to connect only supported IPv6 whereas all the Ignition Server connection were IPv4.

Thanks for the support everyone.