Unable to read String tag for Modbus TCP device

I have connected one machine in Ignition using Modbus TCP protocol. I have received string tag address details from vendor as 407011. I have connected same machine in Kepware and checked the tag data and found there is data in string tag(“Machine Name”). But when I checked in Ignition I am unable to read the string data.
Could you please tell me is there anything wrong in tag address mapping in Ignition.

I have mapped the tags address in Ignition gateway-> Config → Device Connections ->Under Devices(Addresses)

The setting for string tags are(Length 20L)

Prefix = DeviceName ;Start=1; End=1; Step=Unchecked; UnitID = 0; Modbus Type =Holding Register (Int16bit) ; Modbus Address=7011

You are specifying integer reading of the one address.

Consider not using the address mapping tool (it is optional). Simply create an OPC tag and manually enter the following as the OPC Item Path:


Variations to try:


You may also need to adjust the device’s advanced settings for one-based versus zero-based addressing, and possibly also the string byte order setting.

You can see why I made the above suggestions here:


Hi Pturmel,

Thanks for replying. I tried with the following combinations but still not able to read the values.


Browsed Tag for Reference : ns=1;s=[J03_MYE_MASS_303A_001]Devicename1

I recommend capturing what Kepware is doing so we can compare. If that’s too much private info, consider having support look over your shoulder.

Or, perhaps, share your vendor documentation so we can decipher it directly.

Thank you Pturmel,

Your solution worked.
Address combination

Initially the reason for not getting the data was communication issue. I checked using direct connection to the machine with address combination given by you and I was able to see the data.

Thanks Pturmel

1 Like