Unable to start application on a client


I’m trying to launch an application on a client but I keep getting the same error at the same point, the applications runs on other PCs’ fine but not this one.

I get the normal package 1/13 downloading but at the end of package 1, it fails and does a couple of retry’s and then this pops up, Error loading application, ZipException: Zip file must have at least one entry.

The pc is running Windows XP Sp 3 version 2002, IE 8 and Java 7 update 21.

Any assistance would be most grateful.

Which Ignition version are you running? Also, which modules do you have installed?

I have the same problem.
Win XP SP3
Java 7.21
Ignition 7.5.6 with the Works package plus the client serial module

Any help on this please?

Hmmm…tried 7.5.6 with version 1.5.3 of the Serial Client module installed, which was downloaded from the Module Marketplace. The Designer and Client launched normally for me. The fastest way to figure this out is to turn on the Java console, like so:

  1. Open the Windows Control Panel and double-click on the Java icon. This will open the Java Control Panel.
  2. In the Java Control Panel, click on the Advanced tab. Under the Java Console section, click the radio button marked “Show console”. Click OK to close the Java Control Panel.
  3. Try to launch a Client again. A Java console will open when the Client starts, and there should be an error message somewhere in the console. Post the error message here on the forum and we will take a look.


I had the same problem. In my case it was a permissions problem in Java to decompress “*.zip” files

Now it works perfectly.

I hope this helps.