Unable to update a tags alarm config using editTag

I have Ignition v7.7.4.
Through scripting I am creating a tag, and setting up a single alarm condition called “DO Alarm1”.
This appears to work. I can create the tag as scripted.

Later, I want to update the tag’s Display Path in the Alarm from a script (in essence, change the configuration) using:
system.tag.editTag(tagPath=tagFP, alarmConfig={“DO Alarm”:[[“displaypath”, “Value”, newDisplayPath]]})

newDisplayPath is the new text I would like to write.
tagFP is the full path to the tag.

This does not work and there are no errors. Any ideas?

I just tested this on a temp tag of mine and it worked fine.
Test yours in the Script Console and see if it throws an error for you.
Here is the code I used on an alarm named “DO”

system.tag.editTag(tagPath="TempDeleteLater/end_shift",alarmConfig={"DO":[["displaypath", "Value", NewDisplayPath]]})

Very odd. Today it works. I only rebooted my system.
Thanks for the help MMaynardUSG!

More oddness. I added a line to my script to change two alarm parameters, the first one works (display path), but my change to my associated data does not.

system.tag.editTags(tagPath=[tagFP], alarmConfig={"DO Alarm":[["displaypath", "Value", newDisplayPath]]}) 
system.tag.editTags(tagPath=[tagFP], alarmConfig={"DO Alarm":[["OneText", "Value", "CLOSE"]]}) 

I’ll try combining these two lines and see what happens.

Okay, I figured out my mistake. This works:
system.tag.editTag(tagPath=tagFP, alarmConfig={“DO Alarm”:[[“displaypath”, “Expression”, newDisplayPath], [“OneText”,“Value”, “CLOSE”]]})

I was missing a set of square brackets.

what did you do different, it looks the same to me, outside of combining them. I ask because I tried writing to just associated data alone the other day and it wouldnt work.

Is it possible to configure a Bit State Alarm Mode using the system.tag.editTag function?
I’ve tried with

almConf = [['priority', 'Value', 3], \ ['ackMode', 'Value', 1], \ ['mode', 'Value', 13], \ DOES NOT WORK ['bitPosition', 'Value', 5], \ DOES NOT WORK ['timeOnDelaySeconds', 'Value', 3600], \ ['activePipeline', 'Value', 'Basic Pipeline'] \ ] system.tag.editTag(tagPath=fullPath, alarmConfig={"test": almConf})
but it doesn’t work.