Unattended Linux install of 8.1.1

Tried following docs here, and it still prompts me for a username. What did I miss?

ubuntu@dev-ignition1:~$ sudo ./ignition-8.1.1-linux-x64-installer.run -- "unattended=text" "user=ignition"
Verifying archive integrity...  100%   MD5 checksums are OK. All good.
Uncompressing IgnitionInstaller  100%  
Root detected. Please enter a username to install Ignition as: 

Also tried with textMode=true appended onto the end and got the same behavior.

Hmm. Does the “ubuntu” user happen to have uid=0?


cut -d: -f1,3 /etc/passwd

Nope. UID=1000 GID=1000.
But I ran it under sudo so the effective UID was 0.
And the UID of the ignition user is 1001. It’s a normal user account and not a system account.


This is a nearly pristine install of the most recent Ubuntu 18.04 AMI on an AWS EC2 if you want to try it yourself.

Try without sudo, which is what generates the username prompt.

It worked without sudo. I’m assuming it does sudo (or some equivalent) internally in the script as needed?

It also didn’t stop to ask me for a sudo password since the ubuntu account was setup to not need one. Would it have prompted me if one was?

yes it would have prompted if it was required

Has anyone experience with unattended remote installation using tools like Ansible?
I’m trying to get it to work, but the installation hangs either on the input for SU rights or if I run it with SUDO, it comes up with the above mentioned prompt…
Is using the zip-install and the ignition.sh-file the only possible way?

Yes. You just need to have your script sudo to a non-root user that has unprompted sudo privileges to do the install, e.g. on AWS Ubuntu instances, there is a user named “ubuntu” setup the right way:

sudo -u ubuntu ./ignition-8.1.1-linux-x64-installer.run -- "unattended=text" "user=ignition"

If you don’t already have an account setup for sudo w/o password, you may need to make one first. Roundabout, but workable.