User Attributes First Name and Last Name mapped from database provider

Is it possible to map the firstname and lastname attributes from a database provider to the internal identity provider? The attributes are present in the database provider but do not appear in the identity provider (see attached screenshots).
Am i missing a setting or is it simply not possible?
Ignition version is 8.0.7

You should be able to request them as long as you have the scope piece defined correctly in your Ignition IdP setup. See this following entry from the Ignition Manual about this. Step 11 of the configuration part gives some information about configuration in Ignition as well in the above article.


Garth, thank you for this answer. But i don’t see the scope setting in 8.0.7. Is this a new setting in a nightly build?


I apologize for the confusion. In looking at the original configuration I thought you were working with an OpenID connection and had missed setting up the request from the provider. For mapping attributes to items sent by the provider, there is an option under the More link for User Attribute Mapping that should allow you to map this attribute.

Manual Info:



what is the correct path setting for the firstname, lastname and email attributes? I tried paths like ‘lastname’, ‘lname’, ‘Lastname’ and a lot of variations without success.
I found that i can map every attribute that is displayed in the IdP Response Data tab, e.g. aud. But as you can see in the screenshot in my original post, firstname an lastname do not appear in the response data.
I’m sure i am missing a step here, but i have not idea what that can be.

The attributes in the below screen shot should work for you:

@jspecht I already tried this paths, but just checked again to make sure. No success
I’m using the Test Login function on the IdP configuration page and logged out again before changing the mappings.

Is there any special setting required in the Database user source?

If you are using a Database User Source, you need to make sure the firstname / lastname columns are set in your Authentication Query and List Users Query.

Thank you!

Firstname and lastname where missing in the List Users Query. Now it works as expected.

1 Like