Using Ignition with OpenJDK (Windows)?

I’ve been attempting to install/run Ignition using OpenJDK on Windows, but have been running into issues, as Ignition is looking for Oracle Java instead.

Is anyone aware of a guide/best practices for using OpenJDK to run Ignition on Windows?

Thanks in advance.

What issues are you seeing?

Ignition doesn’t look for Oracle Java specifically… unless you’ve got a hard-coded path to it in your ignition.conf.

By default, it just expects Java to be available on $PATH.

For instance, the Native Client Launcher won’t recognize OpenJDK - it gives the following error on launch:

Furthermore, it appears OpenJDK can’t launch Designer by itself - it doesn’t recognize .jnlp files. I’ve looked into IcedTea as a way to launch Designer, but it appears to be only stable on Linux.

Currently, the Native Launcher can’t detect OpenJDK installs, so for now you’ll have to do a workaround. Copy all of the folders from the root of your OpenJDK install (bin, lib, etc) and place them in a jre folder that is sitting in the same directory as your client launcher executable. Not an ideal solution, but it should get your clients/designers up and running.

This workaround solved the issue. Thanks!

On windows. They appear to work fine on Linux. (-:

Yup, that’s correct, thanks for adding that distinction Phil. I believe this is because launch4j only looks for Oracle-specific registry entries for finding JRE/JDK installs on Windows.

I’ve installed ignition twice on two separate machines for development over the last few machines. Both windows and both uses the openJDK with no issues.

I installed openJDK 9 at first and wouldn’t work, once I installed 8 it work straight away.

Found this thread because I am getting the same error as above regarding JRE 1.6.0 when launching the clientlauncher.exe. I have tried copying all the files and folders from an actual Java v6 JRE folder to a “jre” folder in the same location as my clientlauncher.exe and I’m still getting the same error. I even tried with Java 7 & 8 in case the “1.6.0” in the error was wrong, still no luck.

What am I still missing?

Have you been able to resolve this? I’m also still getting the same error.

Upgrade to 7.9.10 and use the native client launchers with embedded Java (from Azul Systems) and you won’t have to worry about system java detection.

The underlying issue in this thread was a problem with launch4j, which switching to an embedded runtime allowed us to avoid using.